Modular Wicket Application

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Modular Wicket Application

IowA
Hello all, I am new to Wicket. When I use Guice in Wicket's quickstart everything works like a charm and it is possible to deploy it on Tomcat. But when i use same code + write my module deploying to Tomcat ends with errors.
Catalina - http://pastebin.com/CaFGzDta
Tomcat - http://pastebin.com/prEU4RX5

wicket module pom.xml - http://pastebin.com/zF0z2MiN
domain module pom.xml - http://pastebin.com/bLkbwhsN
parent pom.xml - http://pastebin.com/hC9sLpuJ

Any ideas what I am doing wrong?
Reply | Threaded
Open this post in threaded view
|

Re: Modular Wicket Application

Paul Bors
I’m no expert, but it looks like your filter is not started right. That should be configured via the web.xml file.

Perhaps you could create a quick-start and package your project for us to see it as a whole?
Only the minimal code that produces the error should be packaged.

On Feb 8, 2014, at 4:12 AM, IowA <[hidden email]> wrote:

> Hello all, I am new to Wicket. When I use Guice in Wicket's quickstart
> everything works like a charm and it is possible to deploy it on Tomcat. But
> when i use same code + write my module deploying to Tomcat ends with errors.
> Catalina - http://pastebin.com/CaFGzDta
> Tomcat - http://pastebin.com/prEU4RX5
>
> wicket module pom.xml - http://pastebin.com/zF0z2MiN
> domain module pom.xml - http://pastebin.com/bLkbwhsN
> parent pom.xml - http://pastebin.com/hC9sLpuJ
>
> Any ideas what I am doing wrong?
>
> --
> View this message in context: http://apache-wicket.1842946.n4.nabble.com/Modular-Wicket-Application-tp4664317.html
> Sent from the Users forum mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

~ Thank you,
    Paul@Bors.ws
Reply | Threaded
Open this post in threaded view
|

Re: Modular Wicket Application

IowA
You can get sample project from github: https://github.com/ReginaldasR/wicket-modular
Reply | Threaded
Open this post in threaded view
|

Re: Modular Wicket Application

Martin Grigorov-4
In reply to this post by IowA
Hi,

You have to use Wicket libraries with the same major version.
wicket is 7.0.0-SNAPSHOT
but wicketstuff-annotation is 1.4

I'd recommend you to use 6.13 for both

Martin Grigorov
Wicket Training and Consulting


On Sat, Feb 8, 2014 at 10:12 AM, IowA <[hidden email]> wrote:

> Hello all, I am new to Wicket. When I use Guice in Wicket's quickstart
> everything works like a charm and it is possible to deploy it on Tomcat.
> But
> when i use same code + write my module deploying to Tomcat ends with
> errors.
> Catalina - http://pastebin.com/CaFGzDta
> Tomcat - http://pastebin.com/prEU4RX5
>
> wicket module pom.xml - http://pastebin.com/zF0z2MiN
> domain module pom.xml - http://pastebin.com/bLkbwhsN
> parent pom.xml - http://pastebin.com/hC9sLpuJ
>
> Any ideas what I am doing wrong?
>
> --
> View this message in context:
> http://apache-wicket.1842946.n4.nabble.com/Modular-Wicket-Application-tp4664317.html
> Sent from the Users forum mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Modular Wicket Application

IowA
Hello, I was not using annotations, so after removing it from pom.xml I am still getting same error

Martin Grigorov-4 wrote
Hi,

You have to use Wicket libraries with the same major version.
wicket is 7.0.0-SNAPSHOT
but wicketstuff-annotation is 1.4

I'd recommend you to use 6.13 for both

Martin Grigorov
Wicket Training and Consulting


On Sat, Feb 8, 2014 at 10:12 AM, IowA <[hidden email]> wrote:

> Hello all, I am new to Wicket. When I use Guice in Wicket's quickstart
> everything works like a charm and it is possible to deploy it on Tomcat.
> But
> when i use same code + write my module deploying to Tomcat ends with
> errors.
> Catalina - http://pastebin.com/CaFGzDta
> Tomcat - http://pastebin.com/prEU4RX5
>
> wicket module pom.xml - http://pastebin.com/zF0z2MiN
> domain module pom.xml - http://pastebin.com/bLkbwhsN
> parent pom.xml - http://pastebin.com/hC9sLpuJ
>
> Any ideas what I am doing wrong?
>
> --
> View this message in context:
> http://apache-wicket.1842946.n4.nabble.com/Modular-Wicket-Application-tp4664317.html
> Sent from the Users forum mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Modular Wicket Application

Martin Grigorov-4
https://github.com/ReginaldasR/wicket-modular/pull/1

Martin Grigorov
Wicket Training and Consulting


On Wed, Feb 12, 2014 at 5:51 PM, IowA <[hidden email]> wrote:

> Hello, I was not using annotations, so after removing it from pom.xml I am
> still getting same error
>
>
> Martin Grigorov-4 wrote
> > Hi,
> >
> > You have to use Wicket libraries with the same major version.
> > wicket is 7.0.0-SNAPSHOT
> > but wicketstuff-annotation is 1.4
> >
> > I'd recommend you to use 6.13 for both
> >
> > Martin Grigorov
> > Wicket Training and Consulting
> >
> >
> > On Sat, Feb 8, 2014 at 10:12 AM, IowA &lt;
>
> > reginaldasr@
>
> > &gt; wrote:
> >
> >> Hello all, I am new to Wicket. When I use Guice in Wicket's quickstart
> >> everything works like a charm and it is possible to deploy it on Tomcat.
> >> But
> >> when i use same code + write my module deploying to Tomcat ends with
> >> errors.
> >> Catalina - http://pastebin.com/CaFGzDta
> >> Tomcat - http://pastebin.com/prEU4RX5
> >>
> >> wicket module pom.xml - http://pastebin.com/zF0z2MiN
> >> domain module pom.xml - http://pastebin.com/bLkbwhsN
> >> parent pom.xml - http://pastebin.com/hC9sLpuJ
> >>
> >> Any ideas what I am doing wrong?
> >>
> >> --
> >> View this message in context:
> >>
> http://apache-wicket.1842946.n4.nabble.com/Modular-Wicket-Application-tp4664317.html
> >> Sent from the Users forum mailing list archive at Nabble.com.
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail:
>
> > users-unsubscribe@.apache
>
> >> For additional commands, e-mail:
>
> > users-help@.apache
>
> >>
> >>
>
>
>
> --
> View this message in context:
> http://apache-wicket.1842946.n4.nabble.com/Modular-Wicket-Application-tp4664317p4664413.html
> Sent from the Users forum mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Modular Wicket Application

IowA
Thanks!

Martin Grigorov-4 wrote
https://github.com/ReginaldasR/wicket-modular/pull/1

Martin Grigorov
Wicket Training and Consulting


On Wed, Feb 12, 2014 at 5:51 PM, IowA <[hidden email]> wrote:

> Hello, I was not using annotations, so after removing it from pom.xml I am
> still getting same error
>
>
> Martin Grigorov-4 wrote
> > Hi,
> >
> > You have to use Wicket libraries with the same major version.
> > wicket is 7.0.0-SNAPSHOT
> > but wicketstuff-annotation is 1.4
> >
> > I'd recommend you to use 6.13 for both
> >
> > Martin Grigorov
> > Wicket Training and Consulting
> >
> >
> > On Sat, Feb 8, 2014 at 10:12 AM, IowA <
>
> > reginaldasr@
>
> > > wrote:
> >
> >> Hello all, I am new to Wicket. When I use Guice in Wicket's quickstart
> >> everything works like a charm and it is possible to deploy it on Tomcat.
> >> But
> >> when i use same code + write my module deploying to Tomcat ends with
> >> errors.
> >> Catalina - http://pastebin.com/CaFGzDta
> >> Tomcat - http://pastebin.com/prEU4RX5
> >>
> >> wicket module pom.xml - http://pastebin.com/zF0z2MiN
> >> domain module pom.xml - http://pastebin.com/bLkbwhsN
> >> parent pom.xml - http://pastebin.com/hC9sLpuJ
> >>
> >> Any ideas what I am doing wrong?
> >>
> >> --
> >> View this message in context:
> >>
> http://apache-wicket.1842946.n4.nabble.com/Modular-Wicket-Application-tp4664317.html
> >> Sent from the Users forum mailing list archive at Nabble.com.
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail:
>
> > users-unsubscribe@.apache
>
> >> For additional commands, e-mail:
>
> > users-help@.apache
>
> >>
> >>
>
>
>
> --
> View this message in context:
> http://apache-wicket.1842946.n4.nabble.com/Modular-Wicket-Application-tp4664317p4664413.html
> Sent from the Users forum mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>