[VOTE] Release Apache Wicket 6.30.0

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

[VOTE] Release Apache Wicket 6.30.0

Andrea Del Bene-3
This is a vote to release Apache Wicket 6.30.0

Please download the source distributions found in our staging area
linked below.

I have included the signatures for both the source archives. This vote
lasts for 72 hours minimum.

[ ] Yes, release Apache Wicket 6.30.0
[ ] No, don't release Apache Wicket 6.30.0, because ...

Distributions, changelog, keys and signatures can be found at:

     https://dist.apache.org/repos/dist/dev/wicket/6.30.0

Staging repository:

https://repository.apache.org/content/repositories/orgapachewicket-1117

The binaries are available in the above link, as are a staging
repository for Maven. Typically the vote is on the source, but should
you find a problem with one of the binaries, please let me know, I can
re-roll them some way or the other.

Staging git repository data:

     Repository:  [hidden email]:bitstorm/wicket.git
     Branch:      build/wicket-6.30.0
     Release tag: rel/wicket-6.30.0


========================================================================

     The signatures for the source release artefacts:


Signature for apache-wicket-6.30.0.zip:

     -----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEE0a6YZHC1pJw+aieyh48B+qjTVuEFAlwIOJcACgkQh48B+qjT
VuHmRw//QpWDqMMoEPh7JhmvUS+6GQ+WJVTfn9nlFtXqMwa/MvQ+22RJgrBWOWQx
is2czsKZ+roHoYztjuk9kfiepjBNtif+kFBzF+cyuyE/6LmG2IjgSTiFbuQKaNyT
MOrDN/W1QgrroWZndLZSfVZFLtsiJ0CNvssfnsc9BuNitPjDE39RHcgXRMHyJVbI
dx69VOokOh0fm86IslV4K1c+l1aYGFRWEoXPJTHOMHi17/FqJV9fRXNHXLHas6Lu
kME35/NhvKynLjh1YZslaYEBCpksTQ6M5ojvf1nb4PFsG8ld+rvMKk9BuJTf18vi
WtrlvSol4o4exSX8r37F5c8tAMmT25Ji6D7a6BZ2f6AdcpXyBDmHxWufzPkJjlgZ
9Lru1bTp0tCvIr7xSZ0DNGKFHc3JC81I49MFklw4aBrcRUuiA5uhJFE/0sYtX8/O
3yMeqPj5CKwqhalNTpBZ/8X2cIOQfR++wF9IvnxB8fsbjm+em0BBWDPkQ2TodScv
iQEfKadw40/AC+CuZ0r4aXOIqNPXQDFVKX1T2zpbiEoZ3iWpwj0K+xAoB3CV7Rik
a2PnFyWcKZrnF/GyV/xeemsS61QB6Y8ArhO8OXBCVfunYpiY41XkYqJpZLrC9MCp
KcKSZDp6ssLYISSYD+vwkw0q/auOLeOUlyXZR8myGyV9SjrDTec=
=u67E
-----END PGP SIGNATURE-----

Signature for apache-wicket-6.30.0.tar.gz:

     -----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEE0a6YZHC1pJw+aieyh48B+qjTVuEFAlwIOJcACgkQh48B+qjT
VuE+NA//Y2zSy+mX1doPmIVkuQ3hFGilcU1yEPU0WlyxMfL6OPBTsE6vfDn7wjRr
/ZE2otecN+CSC1qqmhOo+B+lbszxfafH+TgVMpEbMMvZjCuZFS0ZjAde7PxH1ynB
7tQLyGqDGjdvewmZuOj9f/ICqt7QyhEbQ1t61vk5537g9umZqVv+9tnwy97epCKw
kzjIRIysE5vjG/MmLJl/1QwdB/AfWVr6a32Kr+SbSA9gX0/J3Acu0aFpgQ1HEjD4
YeNZCxjJb7Wv1GmrzwUtWjoLQZ19KRNEOz0Y76LE3UcR9L5ckVM89bmLXZ0ND2Ip
p2JfwlZvw1Fe4Iwi8x/pu9mtGPKpvW50QVp3nPsUn86DZ6uzxfFcCumY9zlI6Pwf
B2t03MSZ3FU/W8oawpqXiTJLX8p6PudCNHO3lRoZ6gmb76IzIlH2e1QsTUPD2Q+E
y2FSxnPfvTLI6QfnKXsDEE833mwa19vEgw4QxjRmcQsgZW5TuzRw9TAKAU7DFLgH
eltCyj4+UPZ/FMwYVSk1J/1v8fyaxRv97Egu1vX/pJxm97yqdfk9iOYcT28uq7Fq
Z302PqS0uXcEx8rKq3IxjK7A60dxAESNDLHXvexELHbQ+dLSkx5K8uVdVkWphdpS
W82xj76VSzsMI0pEZXHhLs0yFgtQSe2tHaTNuuAC7rF/KF8ZVU4=
=z2io
-----END PGP SIGNATURE-----

========================================================================

     CHANGELOG for 6.30.0:


** Bug

     * [WICKET-6551] - LazyInitProxyFactory doesn't work correctly at
Weblogic
     * [WICKET-6553] - SelectOptions doesn't html-encode option values

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Wicket 6.30.0

Martin Grigorov-4
I cannot build it locally with JDK 1.6 due to:

[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-javadoc-plugin:2.10.4:jar (attach-javadocs)
on project wicket-util: MavenReportException: Error while generating
Javadoc:
[ERROR] Exit code: 1 - javadoc: error - invalid flag:
--allow-script-in-comments
[ERROR]
[ERROR] Command line was: /home/martin/devel/java-6/bin/javadoc -J-Xmx256m
-J-Xms128m @options @packages




On Wed, Dec 5, 2018 at 10:53 PM Andrea Del Bene <[hidden email]>
wrote:

> This is a vote to release Apache Wicket 6.30.0
>
> Please download the source distributions found in our staging area
> linked below.
>
> I have included the signatures for both the source archives. This vote
> lasts for 72 hours minimum.
>
> [ ] Yes, release Apache Wicket 6.30.0
> [ ] No, don't release Apache Wicket 6.30.0, because ...
>
> Distributions, changelog, keys and signatures can be found at:
>
>      https://dist.apache.org/repos/dist/dev/wicket/6.30.0
>
> Staging repository:
>
> https://repository.apache.org/content/repositories/orgapachewicket-1117
>
> The binaries are available in the above link, as are a staging
> repository for Maven. Typically the vote is on the source, but should
> you find a problem with one of the binaries, please let me know, I can
> re-roll them some way or the other.
>
> Staging git repository data:
>
>      Repository:  [hidden email]:bitstorm/wicket.git
>      Branch:      build/wicket-6.30.0
>      Release tag: rel/wicket-6.30.0
>
>
> ========================================================================
>
>      The signatures for the source release artefacts:
>
>
> Signature for apache-wicket-6.30.0.zip:
>
>      -----BEGIN PGP SIGNATURE-----
>
> iQIzBAABCgAdFiEE0a6YZHC1pJw+aieyh48B+qjTVuEFAlwIOJcACgkQh48B+qjT
> VuHmRw//QpWDqMMoEPh7JhmvUS+6GQ+WJVTfn9nlFtXqMwa/MvQ+22RJgrBWOWQx
> is2czsKZ+roHoYztjuk9kfiepjBNtif+kFBzF+cyuyE/6LmG2IjgSTiFbuQKaNyT
> MOrDN/W1QgrroWZndLZSfVZFLtsiJ0CNvssfnsc9BuNitPjDE39RHcgXRMHyJVbI
> dx69VOokOh0fm86IslV4K1c+l1aYGFRWEoXPJTHOMHi17/FqJV9fRXNHXLHas6Lu
> kME35/NhvKynLjh1YZslaYEBCpksTQ6M5ojvf1nb4PFsG8ld+rvMKk9BuJTf18vi
> WtrlvSol4o4exSX8r37F5c8tAMmT25Ji6D7a6BZ2f6AdcpXyBDmHxWufzPkJjlgZ
> 9Lru1bTp0tCvIr7xSZ0DNGKFHc3JC81I49MFklw4aBrcRUuiA5uhJFE/0sYtX8/O
> 3yMeqPj5CKwqhalNTpBZ/8X2cIOQfR++wF9IvnxB8fsbjm+em0BBWDPkQ2TodScv
> iQEfKadw40/AC+CuZ0r4aXOIqNPXQDFVKX1T2zpbiEoZ3iWpwj0K+xAoB3CV7Rik
> a2PnFyWcKZrnF/GyV/xeemsS61QB6Y8ArhO8OXBCVfunYpiY41XkYqJpZLrC9MCp
> KcKSZDp6ssLYISSYD+vwkw0q/auOLeOUlyXZR8myGyV9SjrDTec=
> =u67E
> -----END PGP SIGNATURE-----
>
> Signature for apache-wicket-6.30.0.tar.gz:
>
>      -----BEGIN PGP SIGNATURE-----
>
> iQIzBAABCgAdFiEE0a6YZHC1pJw+aieyh48B+qjTVuEFAlwIOJcACgkQh48B+qjT
> VuE+NA//Y2zSy+mX1doPmIVkuQ3hFGilcU1yEPU0WlyxMfL6OPBTsE6vfDn7wjRr
> /ZE2otecN+CSC1qqmhOo+B+lbszxfafH+TgVMpEbMMvZjCuZFS0ZjAde7PxH1ynB
> 7tQLyGqDGjdvewmZuOj9f/ICqt7QyhEbQ1t61vk5537g9umZqVv+9tnwy97epCKw
> kzjIRIysE5vjG/MmLJl/1QwdB/AfWVr6a32Kr+SbSA9gX0/J3Acu0aFpgQ1HEjD4
> YeNZCxjJb7Wv1GmrzwUtWjoLQZ19KRNEOz0Y76LE3UcR9L5ckVM89bmLXZ0ND2Ip
> p2JfwlZvw1Fe4Iwi8x/pu9mtGPKpvW50QVp3nPsUn86DZ6uzxfFcCumY9zlI6Pwf
> B2t03MSZ3FU/W8oawpqXiTJLX8p6PudCNHO3lRoZ6gmb76IzIlH2e1QsTUPD2Q+E
> y2FSxnPfvTLI6QfnKXsDEE833mwa19vEgw4QxjRmcQsgZW5TuzRw9TAKAU7DFLgH
> eltCyj4+UPZ/FMwYVSk1J/1v8fyaxRv97Egu1vX/pJxm97yqdfk9iOYcT28uq7Fq
> Z302PqS0uXcEx8rKq3IxjK7A60dxAESNDLHXvexELHbQ+dLSkx5K8uVdVkWphdpS
> W82xj76VSzsMI0pEZXHhLs0yFgtQSe2tHaTNuuAC7rF/KF8ZVU4=
> =z2io
> -----END PGP SIGNATURE-----
>
> ========================================================================
>
>      CHANGELOG for 6.30.0:
>
>
> ** Bug
>
>      * [WICKET-6551] - LazyInitProxyFactory doesn't work correctly at
> Weblogic
>      * [WICKET-6553] - SelectOptions doesn't html-encode option values
>
>
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Wicket 6.30.0

Martin Grigorov-4
It is quite problematic to build Wicket 6 & 7 these days.

At the top of pom.xml there is a requirement for at least Maven 3.3.9. I
have 2.2.1, 3.5.4 and 3.6.0 here. With 3.5.4 it complains that Maven cannot
work with JDK 1.6.
So I removed the requirement and used Maven 2.2.1 for the build but then
clirr-maven-plugin complained about JDK 1.6, so I downgraded it to 2.7, and
then many other maven-*** plugins started complaining about JDK 1.6
At the end I've used Maven 3.5.4 and JDK 1.7 to build and it failed with
javadoc: error - invalid flag: --allow-script-in-comments
The same happens with JDK 1.8.
So now I wonder how it worked at all for Andrea ?!
The only way I see is to build with JDK 1.8 but without profile 'buildbot',
i.e. without toolchains plugin, but then the produced .class files in the
suggested release should be v.52 and thus are not consumeable by apps still
running on JDK 1.6.
If this is the case then Andrea please revert
https://github.com/apache/wicket/commit/d14a26c61fa397db6177c5f22b546fa30a32e9c5
and make sure you use -Pbuildbot when doing the release(s).

On Thu, Dec 6, 2018 at 11:03 AM Martin Grigorov <[hidden email]>
wrote:

> I cannot build it locally with JDK 1.6 due to:
>
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-javadoc-plugin:2.10.4:jar (attach-javadocs)
> on project wicket-util: MavenReportException: Error while generating
> Javadoc:
> [ERROR] Exit code: 1 - javadoc: error - invalid flag:
> --allow-script-in-comments
> [ERROR]
> [ERROR] Command line was: /home/martin/devel/java-6/bin/javadoc -J-Xmx256m
> -J-Xms128m @options @packages
>
>
>
>
> On Wed, Dec 5, 2018 at 10:53 PM Andrea Del Bene <[hidden email]>
> wrote:
>
>> This is a vote to release Apache Wicket 6.30.0
>>
>> Please download the source distributions found in our staging area
>> linked below.
>>
>> I have included the signatures for both the source archives. This vote
>> lasts for 72 hours minimum.
>>
>> [ ] Yes, release Apache Wicket 6.30.0
>> [ ] No, don't release Apache Wicket 6.30.0, because ...
>>
>> Distributions, changelog, keys and signatures can be found at:
>>
>>      https://dist.apache.org/repos/dist/dev/wicket/6.30.0
>>
>> Staging repository:
>>
>> https://repository.apache.org/content/repositories/orgapachewicket-1117
>>
>> The binaries are available in the above link, as are a staging
>> repository for Maven. Typically the vote is on the source, but should
>> you find a problem with one of the binaries, please let me know, I can
>> re-roll them some way or the other.
>>
>> Staging git repository data:
>>
>>      Repository:  [hidden email]:bitstorm/wicket.git
>>      Branch:      build/wicket-6.30.0
>>      Release tag: rel/wicket-6.30.0
>>
>>
>> ========================================================================
>>
>>      The signatures for the source release artefacts:
>>
>>
>> Signature for apache-wicket-6.30.0.zip:
>>
>>      -----BEGIN PGP SIGNATURE-----
>>
>> iQIzBAABCgAdFiEE0a6YZHC1pJw+aieyh48B+qjTVuEFAlwIOJcACgkQh48B+qjT
>> VuHmRw//QpWDqMMoEPh7JhmvUS+6GQ+WJVTfn9nlFtXqMwa/MvQ+22RJgrBWOWQx
>> is2czsKZ+roHoYztjuk9kfiepjBNtif+kFBzF+cyuyE/6LmG2IjgSTiFbuQKaNyT
>> MOrDN/W1QgrroWZndLZSfVZFLtsiJ0CNvssfnsc9BuNitPjDE39RHcgXRMHyJVbI
>> dx69VOokOh0fm86IslV4K1c+l1aYGFRWEoXPJTHOMHi17/FqJV9fRXNHXLHas6Lu
>> kME35/NhvKynLjh1YZslaYEBCpksTQ6M5ojvf1nb4PFsG8ld+rvMKk9BuJTf18vi
>> WtrlvSol4o4exSX8r37F5c8tAMmT25Ji6D7a6BZ2f6AdcpXyBDmHxWufzPkJjlgZ
>> 9Lru1bTp0tCvIr7xSZ0DNGKFHc3JC81I49MFklw4aBrcRUuiA5uhJFE/0sYtX8/O
>> 3yMeqPj5CKwqhalNTpBZ/8X2cIOQfR++wF9IvnxB8fsbjm+em0BBWDPkQ2TodScv
>> iQEfKadw40/AC+CuZ0r4aXOIqNPXQDFVKX1T2zpbiEoZ3iWpwj0K+xAoB3CV7Rik
>> a2PnFyWcKZrnF/GyV/xeemsS61QB6Y8ArhO8OXBCVfunYpiY41XkYqJpZLrC9MCp
>> KcKSZDp6ssLYISSYD+vwkw0q/auOLeOUlyXZR8myGyV9SjrDTec=
>> =u67E
>> -----END PGP SIGNATURE-----
>>
>> Signature for apache-wicket-6.30.0.tar.gz:
>>
>>      -----BEGIN PGP SIGNATURE-----
>>
>> iQIzBAABCgAdFiEE0a6YZHC1pJw+aieyh48B+qjTVuEFAlwIOJcACgkQh48B+qjT
>> VuE+NA//Y2zSy+mX1doPmIVkuQ3hFGilcU1yEPU0WlyxMfL6OPBTsE6vfDn7wjRr
>> /ZE2otecN+CSC1qqmhOo+B+lbszxfafH+TgVMpEbMMvZjCuZFS0ZjAde7PxH1ynB
>> 7tQLyGqDGjdvewmZuOj9f/ICqt7QyhEbQ1t61vk5537g9umZqVv+9tnwy97epCKw
>> kzjIRIysE5vjG/MmLJl/1QwdB/AfWVr6a32Kr+SbSA9gX0/J3Acu0aFpgQ1HEjD4
>> YeNZCxjJb7Wv1GmrzwUtWjoLQZ19KRNEOz0Y76LE3UcR9L5ckVM89bmLXZ0ND2Ip
>> p2JfwlZvw1Fe4Iwi8x/pu9mtGPKpvW50QVp3nPsUn86DZ6uzxfFcCumY9zlI6Pwf
>> B2t03MSZ3FU/W8oawpqXiTJLX8p6PudCNHO3lRoZ6gmb76IzIlH2e1QsTUPD2Q+E
>> y2FSxnPfvTLI6QfnKXsDEE833mwa19vEgw4QxjRmcQsgZW5TuzRw9TAKAU7DFLgH
>> eltCyj4+UPZ/FMwYVSk1J/1v8fyaxRv97Egu1vX/pJxm97yqdfk9iOYcT28uq7Fq
>> Z302PqS0uXcEx8rKq3IxjK7A60dxAESNDLHXvexELHbQ+dLSkx5K8uVdVkWphdpS
>> W82xj76VSzsMI0pEZXHhLs0yFgtQSe2tHaTNuuAC7rF/KF8ZVU4=
>> =z2io
>> -----END PGP SIGNATURE-----
>>
>> ========================================================================
>>
>>      CHANGELOG for 6.30.0:
>>
>>
>> ** Bug
>>
>>      * [WICKET-6551] - LazyInitProxyFactory doesn't work correctly at
>> Weblogic
>>      * [WICKET-6553] - SelectOptions doesn't html-encode option values
>>
>>
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Wicket 6.30.0

Sven Meier
 
 
+1 to release
 

 
Successfully built with Maven 3.5.3 on Java 1.8.0
 

 
I've had a lot of troubles with building any Wicket version recently, we should definitely improve the situation for all branches.
 
This one worked fine though
 

 
Sven
 

 
 

 
 
 
 
 
>  
> On 06.12.2018 at 10:17,  <Martin Grigorov>  wrote:
>  
>  
>  It is quite problematic to build Wicket 6  &  7 these days. At the top of pom.xml there is a requirement for at least Maven 3.3.9. I have 2.2.1, 3.5.4 and 3.6.0 here. With 3.5.4 it complains that Maven cannot work with JDK 1.6. So I removed the requirement and used Maven 2.2.1 for the build but then clirr-maven-plugin complained about JDK 1.6, so I downgraded it to 2.7, and then many other maven-*** plugins started complaining about JDK 1.6 At the end I've used Maven 3.5.4 and JDK 1.7 to build and it failed with javadoc: error - invalid flag: --allow-script-in-comments The same happens with JDK 1.8. So now I wonder how it worked at all for Andrea ?! The only way I see is to build with JDK 1.8 but without profile 'buildbot', i.e. without toolchains plugin, but then the produced .class files in the suggested release should be v.52 and thus are not consumeable by apps still running on JDK 1.6. If this is the case then Andrea please revert https://github.com/apache/wicket/commit/d14a2
6c61fa397db6177c5f22b546fa30a32e9c5 and make sure  you use -Pbuildbot when doing the release(s). On Thu, Dec 6, 2018 at 11:03 AM Martin Grigorov wrote:  >  I cannot build it locally with JDK 1.6 due to:  >   >  [ERROR] Failed to execute goal  >  org.apache.maven.plugins:maven-javadoc-plugin:2.10.4:jar (attach-javadocs)  >  on project wicket-util: MavenReportException: Error while generating  >  Javadoc:  >  [ERROR] Exit code: 1 - javadoc: error - invalid flag:  >  --allow-script-in-comments  >  [ERROR]  >  [ERROR] Command line was: /home/martin/devel/java-6/bin/javadoc -J-Xmx256m  >  -J-Xms128m @options @packages  >   >   >   >   >  On Wed, Dec 5, 2018 at 10:53 PM Andrea Del Bene  >  wrote:  >   >>  This is a vote to release Apache Wicket 6.30.0  >>   >>  Please download the source distributions found in our staging area  >>  linked below.  >>   >>  I have included the signatures for both the source archives. This vote  >>  lasts for 72 hours minimum.  >>   >>  [ ] Yes, release Apach
e Wicket 6.30.0  >>  [ ] No, don't release Apache Wicket 6.30.0, because ...  >>   >>  Distributions, changelog, keys and signatures can be found at:  >>   >>  https://dist.apache.org/repos/dist/dev/wicket/6.30.0  >>   >>  Staging repository:  >>   >>  https://repository.apache.org/content/repositories/orgapachewicket-1117  >>   >>  The binaries are available in the above link, as are a staging  >>  repository for Maven. Typically the vote is on the source, but should  >>  you find a problem with one of the binaries, please let me know, I can  >>  re-roll them some way or the other.  >>   >>  Staging git repository data:  >>   >>  Repository: [hidden email]:bitstorm/wicket.git  >>  Branch: build/wicket-6.30.0  >>  Release tag: rel/wicket-6.30.0  >>   >>   >>  ========================================================================  >>   >>  The signatures for the source release artefacts:  >>   >>   >>  Signature for apache-wicket-6.30.0.zip:  >>   >>  -----BEGIN PGP SIGNATURE-----  
>>   >>  iQIzBAABCgAdFiEE0a6YZHC1pJw+aieyh48B+qjTVuEFAlwIOJcACgkQh48B+qjT  >>  VuHmRw//QpWDqMMoEPh7JhmvUS+6GQ+WJVTfn9nlFtXqMwa/MvQ+22RJgrBWOWQx  >>  is2czsKZ+roHoYztjuk9kfiepjBNtif+kFBzF+cyuyE/6LmG2IjgSTiFbuQKaNyT  >>  MOrDN/W1QgrroWZndLZSfVZFLtsiJ0CNvssfnsc9BuNitPjDE39RHcgXRMHyJVbI  >>  dx69VOokOh0fm86IslV4K1c+l1aYGFRWEoXPJTHOMHi17/FqJV9fRXNHXLHas6Lu  >>  kME35/NhvKynLjh1YZslaYEBCpksTQ6M5ojvf1nb4PFsG8ld+rvMKk9BuJTf18vi  >>  WtrlvSol4o4exSX8r37F5c8tAMmT25Ji6D7a6BZ2f6AdcpXyBDmHxWufzPkJjlgZ  >>  9Lru1bTp0tCvIr7xSZ0DNGKFHc3JC81I49MFklw4aBrcRUuiA5uhJFE/0sYtX8/O  >>  3yMeqPj5CKwqhalNTpBZ/8X2cIOQfR++wF9IvnxB8fsbjm+em0BBWDPkQ2TodScv  >>  iQEfKadw40/AC+CuZ0r4aXOIqNPXQDFVKX1T2zpbiEoZ3iWpwj0K+xAoB3CV7Rik  >>  a2PnFyWcKZrnF/GyV/xeemsS61QB6Y8ArhO8OXBCVfunYpiY41XkYqJpZLrC9MCp  >>  KcKSZDp6ssLYISSYD+vwkw0q/auOLeOUlyXZR8myGyV9SjrDTec=  >>  =u67E  >>  -----END PGP SIGNATURE-----  >>   >>  Signature for apache-wicket-6.30.0.tar.gz:  >>   >>  -----BEGIN PGP SIGNATURE-----  >>   >>  iQIzBAABCgAdFiEE0a6
YZHC1pJw+aieyh48B+qjTVuEFAlwIOJcACgkQh48B+qjT  >>  VuE+NA//Y2zSy+mX1doPmIVkuQ3hFGilcU1yEPU0WlyxMfL6OPBTsE6vfDn7wjRr  >>  /ZE2otecN+CSC1qqmhOo+B+lbszxfafH+TgVMpEbMMvZjCuZFS0ZjAde7PxH1ynB  >>  7tQLyGqDGjdvewmZuOj9f/ICqt7QyhEbQ1t61vk5537g9umZqVv+9tnwy97epCKw  >>  kzjIRIysE5vjG/MmLJl/1QwdB/AfWVr6a32Kr+SbSA9gX0/J3Acu0aFpgQ1HEjD4  >>  YeNZCxjJb7Wv1GmrzwUtWjoLQZ19KRNEOz0Y76LE3UcR9L5ckVM89bmLXZ0ND2Ip  >>  p2JfwlZvw1Fe4Iwi8x/pu9mtGPKpvW50QVp3nPsUn86DZ6uzxfFcCumY9zlI6Pwf  >>  B2t03MSZ3FU/W8oawpqXiTJLX8p6PudCNHO3lRoZ6gmb76IzIlH2e1QsTUPD2Q+E  >>  y2FSxnPfvTLI6QfnKXsDEE833mwa19vEgw4QxjRmcQsgZW5TuzRw9TAKAU7DFLgH  >>  eltCyj4+UPZ/FMwYVSk1J/1v8fyaxRv97Egu1vX/pJxm97yqdfk9iOYcT28uq7Fq  >>  Z302PqS0uXcEx8rKq3IxjK7A60dxAESNDLHXvexELHbQ+dLSkx5K8uVdVkWphdpS  >>  W82xj76VSzsMI0pEZXHhLs0yFgtQSe2tHaTNuuAC7rF/KF8ZVU4=  >>  =z2io  >>  -----END PGP SIGNATURE-----  >>   >>  ========================================================================  >>   >>  CHANGELOG for 6.30.0:  >>   >>   >>  ** Bug  >>   >>  * [
WICKET-6551] - LazyInitProxyFactory doesn't work correctly at  >>  Weblogic  >>  * [WICKET-6553] - SelectOptions doesn't html-encode option values  >>   >>  
>  
     
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Wicket 6.30.0

Andrea Del Bene-3
Hi,

I forgot to remove the commit from 6.x branch. The well-known
'--allow-script-in-comments' flag has been introduced for Oracle JDK 6 with
build 1.6.0_141-b12. I wrongly assumed that OpenJDK followed the same
update train, so I used OpenJDK 6 u119 from Azul, which actually contains
the support for the flag. That's why I haven't noted any problem. I can
remove the commit as Martin suggested and I successfully executed the build
process with an older OpenJDK build 31 taken from here:
https://github.com/alexkasko/openjdk-unofficial-builds. I know it's not an
official distribution but it really saved me a lot of time and I can't find
a better solution.

On Thu, Dec 6, 2018 at 11:53 AM sven <[hidden email]> wrote:

>
>
> +1 to release
>
>
>
> Successfully built with Maven 3.5.3 on Java 1.8.0
>
>
>
> I've had a lot of troubles with building any Wicket version recently, we
> should definitely improve the situation for all branches.
>
> This one worked fine though
>
>
>
> Sven
>
>
>
>
>
>
>
>
>
>
--
Andrea Del Bene.
Apache Wicket committer.
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Wicket 6.30.0

Martin Grigorov-4
+1 to release

I've downloaded zulu6.22.0.3-jdk6.0.119-linux_x64 and now everything is
fine if I run Maven 3.6.0 with Java 8 and toolchains pointing to Zulu 6.

On Thu, Dec 6, 2018 at 1:21 PM Andrea Del Bene <[hidden email]> wrote:

> Hi,
>
> I forgot to remove the commit from 6.x branch. The well-known
> '--allow-script-in-comments' flag has been introduced for Oracle JDK 6 with
> build 1.6.0_141-b12. I wrongly assumed that OpenJDK followed the same
> update train, so I used OpenJDK 6 u119 from Azul, which actually contains
> the support for the flag. That's why I haven't noted any problem. I can
> remove the commit as Martin suggested and I successfully executed the build
> process with an older OpenJDK build 31 taken from here:
> https://github.com/alexkasko/openjdk-unofficial-builds. I know it's not an
> official distribution but it really saved me a lot of time and I can't find
> a better solution.
>
> On Thu, Dec 6, 2018 at 11:53 AM sven <[hidden email]> wrote:
>
> >
> >
> > +1 to release
> >
> >
> >
> > Successfully built with Maven 3.5.3 on Java 1.8.0
> >
> >
> >
> > I've had a lot of troubles with building any Wicket version recently, we
> > should definitely improve the situation for all branches.
> >
> > This one worked fine though
> >
> >
> >
> > Sven
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> --
> Andrea Del Bene.
> Apache Wicket committer.
>
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Wicket 6.30.0

Maxim Solodovnik
+1

checksums/signatures OK (old format, hard to check)
Build under Oracle jdk1.6.0_45 fail as-is
Build is Ok after commenting/removing '--allow-script-in-comments'

On Fri, 7 Dec 2018 at 03:13, Martin Grigorov <[hidden email]> wrote:

> +1 to release
>
> I've downloaded zulu6.22.0.3-jdk6.0.119-linux_x64 and now everything is
> fine if I run Maven 3.6.0 with Java 8 and toolchains pointing to Zulu 6.
>
> On Thu, Dec 6, 2018 at 1:21 PM Andrea Del Bene <[hidden email]>
> wrote:
>
> > Hi,
> >
> > I forgot to remove the commit from 6.x branch. The well-known
> > '--allow-script-in-comments' flag has been introduced for Oracle JDK 6
> with
> > build 1.6.0_141-b12. I wrongly assumed that OpenJDK followed the same
> > update train, so I used OpenJDK 6 u119 from Azul, which actually contains
> > the support for the flag. That's why I haven't noted any problem. I can
> > remove the commit as Martin suggested and I successfully executed the
> build
> > process with an older OpenJDK build 31 taken from here:
> > https://github.com/alexkasko/openjdk-unofficial-builds. I know it's not
> an
> > official distribution but it really saved me a lot of time and I can't
> find
> > a better solution.
> >
> > On Thu, Dec 6, 2018 at 11:53 AM sven <[hidden email]> wrote:
> >
> > >
> > >
> > > +1 to release
> > >
> > >
> > >
> > > Successfully built with Maven 3.5.3 on Java 1.8.0
> > >
> > >
> > >
> > > I've had a lot of troubles with building any Wicket version recently,
> we
> > > should definitely improve the situation for all branches.
> > >
> > > This one worked fine though
> > >
> > >
> > >
> > > Sven
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > --
> > Andrea Del Bene.
> > Apache Wicket committer.
> >
>


--
WBR
Maxim aka solomax
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Wicket 6.30.0

Andrea Del Bene-3
This vote passes.Thank you all!

On 07/12/18 03:58, Maxim Solodovnik wrote:

> +1
>
> checksums/signatures OK (old format, hard to check)
> Build under Oracle jdk1.6.0_45 fail as-is
> Build is Ok after commenting/removing '--allow-script-in-comments'
>
> On Fri, 7 Dec 2018 at 03:13, Martin Grigorov <[hidden email]> wrote:
>
>> +1 to release
>>
>> I've downloaded zulu6.22.0.3-jdk6.0.119-linux_x64 and now everything is
>> fine if I run Maven 3.6.0 with Java 8 and toolchains pointing to Zulu 6.
>>
>> On Thu, Dec 6, 2018 at 1:21 PM Andrea Del Bene <[hidden email]>
>> wrote:
>>
>>> Hi,
>>>
>>> I forgot to remove the commit from 6.x branch. The well-known
>>> '--allow-script-in-comments' flag has been introduced for Oracle JDK 6
>> with
>>> build 1.6.0_141-b12. I wrongly assumed that OpenJDK followed the same
>>> update train, so I used OpenJDK 6 u119 from Azul, which actually contains
>>> the support for the flag. That's why I haven't noted any problem. I can
>>> remove the commit as Martin suggested and I successfully executed the
>> build
>>> process with an older OpenJDK build 31 taken from here:
>>> https://github.com/alexkasko/openjdk-unofficial-builds. I know it's not
>> an
>>> official distribution but it really saved me a lot of time and I can't
>> find
>>> a better solution.
>>>
>>> On Thu, Dec 6, 2018 at 11:53 AM sven <[hidden email]> wrote:
>>>
>>>>
>>>> +1 to release
>>>>
>>>>
>>>>
>>>> Successfully built with Maven 3.5.3 on Java 1.8.0
>>>>
>>>>
>>>>
>>>> I've had a lot of troubles with building any Wicket version recently,
>> we
>>>> should definitely improve the situation for all branches.
>>>>
>>>> This one worked fine though
>>>>
>>>>
>>>>
>>>> Sven
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>> --
>>> Andrea Del Bene.
>>> Apache Wicket committer.
>>>
>